Support

  • For installation and troubleshooting, please refer to:
    • Primary Sense Services Installation and Troubleshooting,
    • If Primary Sense Services are using excessive database resources or otherwise causing an issue, please stop and disable all Windows Services,
    • Primary Sense Desktop Installation and Troubleshooting.
    • If Primary Sense Desktop is using excessive database resources or otherwise causing an issue, please right-click and select Exit to close the application.
  • Contact Primary Sense for further support.

Downloads

Desktop Software

Notes:

  • Install on each practice desktop or laptop computer using Primary Sense.
  • Desktop is 32 bit (x86) and may run on a 32 or 64 bit operating system.
  • If Primary Sense Desktop v1.0.69 is currently installed, use the Primary Sense Desktop Updater to update to the latest version.
  • Installation and use of this software is governed by the End User License Agreement,
Software Package Version Release Size Download Instructions
UPDATEDPrimary Sense Desktop 1.0.77 July 2021 8 MB Download View
UPDATEDPrimary Sense Desktop Updater Use to update v1.0.69 to v1.0.77 7 MB Download
Server Software

Notes:

  • Install on one Server per practice only.
  • Install both software packages to enable automated service updates.
  • Services are 64 bit (x64) and require a 64 bit operating system.
  • If Primary Sense Extractor v1 is currently installed and there is an error removing it via the standard Windows uninstallation method, use the Primary Sense Extractor (v1) Uninstaller to remove it.
  • Installation and use of this software is governed by the End User License Agreement,
Software Package Version Release Size Download Instructions
Primary Sense Services (Extractor) 2.0.1 April 2020 8 MB Download View
Primary Sense Services (Extractor) Updater 2.0.1 April 2020 4 MB Download View
Primary Sense Extractor (v1) Uninstaller 1.0.2 February 2021 83 KB Download

Practice Software Prerequisites

If your practice is running Best Practice software and is updated to Jade with October 2019 Data Update or newer, then you will need to configure Third Party Access to allow Primary Sense to access the database.

You can configure this by selecting Setup within Best Practice, then selecting Configuration and then Database.

Click the Setup third-party integrations button and then scroll down the list of third-party providers and tick Primary Care Gold Coast.

Click Save, then Save again.

Best Practice Third Party Integration
Best Practice Third Party Integration

Click Here for full instructions on how to enable Third Party Access for Primary Sense

If your practice is running Medical Director, you will need to download the SQL script below. This script will set up a read only user account which will be used when configuring Primary Sense Services.

Replace the <insert password here> text with a secure random password.

Run the script on your Medical Director SQL Database using Microsoft SQL Management Studio.

Download Create User Script

If you previously have run the Create User Script and have recently updated Medical Director to a new version, the user may have lost access to the database. Run the following script to fix the user permissions.

Download Update User Script

Supported Operating Systems

Primary Sense is supported on the following Microsoft Windows® operating systems:

Notes:

  • Desktop is 32 bit (x86) and may run on a 32 or 64 bit operating system,
  • Services are 64 bit (x64) and require a 64 bit operating system.

Desktop

  • Windows 10
  • Windows 8.1
  • Windows 7 with Service Pack 1 END OF LIFE

Server

  • Windows Server 2019
  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2012
  • Windows Server 2008 R2 with Service Pack 1 END OF LIFE

Not Supported

The following operating systems are not supported:

Desktop

Server

  • Windows Server 2008 and earlier

End of Life

Operating systems marked as END OF LIFE are no longer supported by Microsoft. Primary Sense will run on these operating systems but we recommend you upgrade to continue to receive security and quality updates.

Microsoft .Net Framework

Microsoft .Net Framework v4.6.2 or newer is a requirement for running the Primary Sense software.

Notes:

  • The framework is already installed on many modern Windows computers, or may already be installed by your practice software.
  • We recommend installing the latest available version.
  • Installation or upgrading may require a reboot to complete.
  • Run Windows Update after installation to ensure all security and quality updates are installed.
Software Package Version Download
Microsoft .Net Framework 4.8 RECOMMENDED Download All Versions
Microsoft .Net Framework 4.6.2 MINIMUM Download